Timme Hosting hat die optimale PHP-Version für Ihre Website (PHP 5.4, 5.3, 5.2)

Timme Hosting hat die optimale PHP-Version für Ihre Website (PHP 5.4, 5.3, 5.2)

Jeder, der sich etwas häufiger mit PHP-Anwendungen beschäftigt, weiß, daß auch die eingesetzte PHP-Version darüber entscheidet, ob eine Anwendung vollständig funktioniert oder nur teilweise oder gar nicht. Oder anders ausgedrückt: nicht alle PHP-Anwendungen unterstützen alle PHP-Versionen. Ein aktuelles Beispiel ist TYPO3 4.7.x, das die PHP-Version 5.3.x benötigt, aber unter dem neuesten PHP 5.4.x nicht vollständig funktioniert. Auch Drupal 7 hat teilweise Probleme mit PHP 5.4.x.

Deswegen haben wir bei Timme Hosting auf unseren Servern jeweils mehrere PHP-Versionen installiert und setzen automatisch jeweils die am besten von Ihrer Webanwendung unterstützte PHP-Version ein. Su klappt beispielsweise auch das Drupal-Hosting reibungslos. Zur Auswahl stehen momentan PHP 5.4.4, welches wir als Standard einsetzen, sowie PHP 5.3.15 und auch PHP 5.2.17, welches z.B. von älteren Shopware-Versionen benötigt wird, die noch einen installierten ZendOptimizer erfordern, der aber nur bis PHP 5.2.x verfügbar ist.

Bei allen PHP-Versionen setzen wir Xcache als PHP-Cache ein, der sich in unseren Tests als etwas schneller und vor allem stabiler als der vergleichbare APC erwiesen hat.

Als Hosting-Kunde können Sie uns gerne mitteilen, falls Sie eine bestimmte PHP-Version für Ihre Anwendung bevorzugen.

Nach oben